Author Topic: Coolant Bleeder Valve Installation  (Read 1168 times)

0 Members and 1 Guest are viewing this topic.

Offline ag86IL

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 604
  • Karma: +7/-0
Coolant Bleeder Valve Installation
« on: November 04, 2012, 08:09:50 PM »
There are many reports of gurgling water sounds in the heater core, also many threads on blown head gaskets. Air in the coolant pops head gaskets. The air has nowhere to go without a bleeder valve. So I\'m fixing that.


This is a bleeder valve from a 1986 Toyota Mr2, due to mid engine layout this vehicle has three bleed points. And it is critical to properly bleed coolant on these cars. One on the thermostat housing, one on the radiator, and one on a heater hose in front trunk. The one right off the heater core is the one I\'m using.




It will be mounted so it is the highest point of cooling system.


SI_daihatsu

  • Guest
Re: Coolant Bleeder Valve Installation
« Reply #1 on: November 04, 2012, 11:47:24 PM »
Can u show a pic of how u r t ing into the heater core lines

Offline ag86IL

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 604
  • Karma: +7/-0
Re: Coolant Bleeder Valve Installation
« Reply #2 on: November 05, 2012, 12:25:55 AM »
Quote from: \"SI_daihatsu\" post=2834919
Can u show a pic of how u r t ing into the heater core lines


I\'ll snap a few more pics after I mod the mount for it. The top line from heater core (coolant exit) goes into valve and then returns up by the thermostat. I looked in the service manual to check the coolant flow so it\'s hooked to valve correctly. The coolant bleeder valve has an arrow on it.


This actually turns the heat on in the mr2, but I don\'t think there will be any problems with valve closing due to driving around, if there is a problem I\'ll find a way to keep it open.

SI_daihatsu

  • Guest
Re: Coolant Bleeder Valve Installation
« Reply #3 on: November 05, 2012, 12:31:41 AM »
Cool this is prolly something I may do since I think I do have a lil bit of air in my coolant system

Offline ag86IL

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 604
  • Karma: +7/-0
Re: Coolant Bleeder Valve Installation
« Reply #4 on: November 05, 2012, 12:55:01 AM »
Ya, after all this work I\'ve been doing (went after the timing belt), I filled with water and let it get full warm. The heater core gurgled some. After it cooled I pulled the coolant line going to Idle Air Control Valve on the the throttle body, and nothing came out. The radiator was full. That is a lot of air, and it\'s a serious problem.

Offline ag86IL

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 604
  • Karma: +7/-0
Re: Coolant Bleeder Valve Installation
« Reply #5 on: November 17, 2012, 01:52:46 AM »
Making a mount consisted of digging though box of various little mr2 mounts and then drilling a few small holes. Then mounted behind EGR valve bracket. Highly suspect a very small heater core leak, inside tends to fog quickly and am unable to get all the air out.






 







SI_daihatsu

  • Guest
Re: Coolant Bleeder Valve Installation
« Reply #6 on: November 17, 2012, 02:53:52 AM »
Looks factory

Offline Kaka do

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Coolant Bleeder Valve Installation
« Reply #7 on: October 08, 2018, 02:26:40 AM »
Ya, after all this work I\'ve been doing (went after the timing belt), I filled with water and let it get full warm. The heater core gurgled some. After it cooled I pulled the coolant line going to Idle Air Control Valve on the the throttle body, and nothing came out. The radiator was full. That is a lot of air, and it\'s a serious problem.

I have pulled the coolant line to the inlet side of idle air control valve and have no water flowing out.(the one with one yellow stripe on it in the attached picture)  How can I bleed the air out of the system completely?
I have tried putting a full funnel into the top of the radiator with the engine running and this did get a lot of air out by squeezing hoses etc but still no water flow. Even with the heater on and allowing the engine to get up to temp for over an hour.

Next I put a camera down the inlet water line rubber hose to make sure it wasn’t blocked, and it wasn’t. I can see all the way to where it is connected to the head below the intake manifold, with no obstructions.

I then confirmed the return line to the thermostat housing was clear and got plenty of water out of that line. But still no water on the input side of the idle control valve.
Any one got any thoughts?
1993 SE Feroza (Go Fast Red) 😎 🇦🇺
50mm Tough Dog lift kit, 120A/H dual battery.